Degraded Performance of the Upload Feature
Incident Report for DRACOON Cloud
Postmortem

We experienced an issue with the upload feature on 20.03.2024 afternoon after updating one of our backend components. Our team has worked diligently to identify the root cause and implement a resolution. In this post-mortem, we want to share the details of what happened, why it happened, what we did to resolve it, and what we will do to prevent similar incidents in the future.

What happened? After the update of one of our backend components uploads for a small amount of our customers were delayed.

Why did this happen? The update introduced an edge case, which resulted in some uploads occasionally getting delayed for a small amount of our customers.

What did we do? Our incident response team quickly identified the underlying issue and resolved it for the affected component.

What can we do to improve? We will extend our test cases to identify such issues before a production rollout.

We apologize for any inconvenience this incident may have caused. We are committed to ensuring the stability and reliability of our services and will continue to take proactive measures to prevent similar incidents from happening in the future.

If you have any questions or concerns, please don't hesitate to reach out to our support team for assistance.

Posted Mar 21, 2024 - 12:55 CET

Resolved
The issue with the Upload Feature has been fully resolved. All systems are now operating normally. We apologize for any inconvenience this may have caused and appreciate your patience. If you continue to experience any issues, please don't hesitate to reach out to our support team for assistance.
Posted Mar 20, 2024 - 16:30 CET
Monitoring
The issue with the Upload Feature has been resolved, and we are monitoring the situation to ensure it remains stable. We apologize for any inconvenience this may have caused and appreciate your patience.
Posted Mar 20, 2024 - 16:00 CET
Identified
We have identified the issue with the Upload Feature. Our engineers are working on a resolution and we are confident that we will have a fix in place soon. We will provide more information and updates as soon as they become available.
Posted Mar 20, 2024 - 15:00 CET
Investigating
We are currently investigating an issue with the Upload Feature. Our team is working to gather more information and resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and will provide updates as soon as we have them.
Posted Mar 20, 2024 - 14:00 CET
This incident affected: Storage (Upload).